Glock Forum banner
1 - 13 of 13 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
Hello I am new here and have completed my first build a p80 g26 which I purchased from a local gun show as an entire kit I put it all together and it racks smoothly but the trigger doesn't work it is completely dead and will not engage when racked p80 Ralph has a video that is exactly my issue but I've been at it for 2 entire days and I've been all over YouTube this forum and more no matter what I do or tweak it doesn't work the entire lower kit is all p80 brand and I'm pretty much at an impasse I've spent alot of time and money on something that is effectively a nice paperweight at the moment and I'm in California so seeking help in my state from other people in person is pretty much nonexistent my current plan to to get a new trigger kit and try that but idk what else to do the vendor has offered a new lower kit but it will still be p80 brand parts
 

· Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
I had that issue and despite my being sure I had the slide release spring installed correctly, that’s what was messing everything up. I eventually got it installed correctly.
Good luck and welcome aboard!
I had that issue and d
I had that issue and despite my being sure I had the slide release spring installed correctly, that’s what was messing everything up. I eventually got it installed correctly.
Good luck and welcome aboard!
What is the correct way?
 

· Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
This helps a bit I noticed the spring is poking through slightly next to the trigger and the trigger itself seems to angle to the right and does not sit flush as if the trigger bar is bent in the spot the actual trigger attaches to
 

· Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Hello everyone I have recieved an armorers plate and OEM trigger components and all my problems are solved I test fired 20 or so rounds and now I'm chasing some feeding issues but I can shoot now which is a major improvement and now I am super knowledgeable about the inner workings of glocks and can dissemble one with ease thanks so much
 

· Premium Member
Joined
·
10,882 Posts
Hello everyone I have recieved an armorers plate and OEM trigger components and all my problems are solved I test fired 20 or so rounds and now I'm chasing some feeding issues but I can shoot now which is a major improvement and now I am super knowledgeable about the inner workings of glocks and can dissemble one with ease thanks so much
Good to hear, can you explain you feeding issues, perhaps there could be help with those as well.
 

· Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Good to hear, can you explain you feeding issues, perhaps there could be help with those as well.


I only shot about 30 rounds but the bullets would catch up on the barrel and I had one stovepipe also the slide was not going forward all the way i did some more sanding on the frame and it is racking smoother but haven't gotten any range time since the touch ups but lots of time racking it while empty and oiled to work everything out and try to smooth it up
 

· Premium Member
Joined
·
10,882 Posts
I only shot about 30 rounds but the bullets would catch up on the barrel and I had one stovepipe also the slide was not going forward all the way i did some more sanding on the frame and it is racking smoother but haven't gotten any range time since the touch ups but lots of time racking it while empty and oiled to work everything out and try to smooth it up
If it continues after your smoothing be sure to check the transition area forward of the locking block area towards the muzzle, make sure that it isn't catching your recoil spring in any way.
Because if it is it can cause retardation of the spring and cause the symptoms you describe.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top