Malfunction

Discussion in 'Glock Forum' started by lovemyglock, Apr 21, 2012.

  1. lovemyglock

    lovemyglock New Member

    15
    0
    Had a failure to feed today at the range with my 17g4. I was shooting Remington 147g, and the slide wouldn't go all the way forward and the round was half fed at a slight angle. I had to eject the magazine and only then I was able to clear the round. I checked the spring and feeding path and everything seemed ok. I'm going with a ammo malfunction on this one. Just want to hear your thoughts, and similar experiences.
     
  2. SHOOTER13

    SHOOTER13 RETIRED MODERATOR Sponsor Lifetime Supporting Member

    Are you saying you had one failure to feed...out of how many rounds downrange ?
     

  3. chilly613

    chilly613 New Member

    1,213
    0
    Tap, Rack, Bang or Lock, Drop, Clear, Feed, Bang. All you need.
     
  4. lovemyglock

    lovemyglock New Member

    15
    0
    I had 3 rounds out of 200 fial. I bought a case of 500 and I checked the rest when I got home pulled 2 out with cracked casings out of the rest.
     
  5. SHOOTER13

    SHOOTER13 RETIRED MODERATOR Sponsor Lifetime Supporting Member

    So then, not the Glocks fault...just bad ammo !
     
  6. steverich88

    steverich88 New Member

    76
    0
    This happened to me last week at the range it was my fault because the last round wasn't placed properly no one says it but if you have not broken you mag all the way in the spring my give you issues I learned this first hand