Glock Firearms banner
1 - 6 of 6 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 · (Edited)
Took my new Gen3 Glock 30 out to the range today and immediately starting having problems. It is randomly failing to completely return to battery when firing. I'm having to bump it forward to keep firing. This happens intermittently but always occurs at least once per magazine, sometimes twice.
This gun was broken down and thoroughly cleaned and lubed before taking to the range. I fired about 200 rounds through it total and the issue did not improve over time with some break-in.
I know this was reported with the SF model but I can't find much information on the 30 with this issue. Has anyone seen this with the model 30 and can give me some insight as to what I need to look for in order to resolve this?
I tried 3 different types of ammunition to rule that out. WWB, Federal HST, and Remington GS
 

·
Premium Member
Joined
·
1,516 Posts
Glocks don't need breakin.

Is the gun brand spanking new in the box or used but new to you?
When you cleaned it, how far did you go in disassembly? Only slide off the frame or did you just take the slide all apart?

Did you disassemble the frame?

Did you disassemble the mags?
 

·
Banned
Joined
·
1,000 Posts
Welcome cpaustin! Good luck , someone will get to the bottom of this. Enjoy the forum!
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #5 ·
Thanks for the response everyone. I changed the recoil spring assembly at the suggestion of a glock armorer. Bought a replacement at gt dist here locally. Just got back from the range and problem no longer exists.
 

·
Banned
Joined
·
1,000 Posts
Thanks for the response everyone. I changed the recoil spring assembly at the suggestion of a glock armorer. Bought a replacement at gt dist here locally. Just got back from the range and problem no longer exists.
Now that's awesome! Enjoy your GLOCK!!
 
1 - 6 of 6 Posts
Top