Glock Firearms banner

1 - 19 of 19 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I went to the range today, working on trigger control and experienced some interesting behavior from my Glock pistol.

I was working on trigger control -- not fully releasing the trigger with each shot, but firing and then SLOWLY letting the trigger release just until the reset. Then next shot, same thing. On the last round in each mag, the bolt would hang (not in battery, nor fully locked backed), and the trigger would not reset -- it would stick in the rear (pulled) position.

The only way I found to clear this was to drop the mag, and then manually rack the slide.
With the mag still in place, the slide would not fully rack (was jammed) and the trigger would not reset.

Is this normal/expected? Anyone else see this behavior, or know why it happens?

250 rounds -- the pistol performed fine except for these few (always) at end-of-mag. Also, all other rounds where I let the trigger reset normally after a shot, were fine (even end-of-mag rounds).

Configurations:
Pistol - Stock Glock 34, Gen5 (no mods)
Mags - Stock Glock Mags (came with pistol)
Ammo - S&B 115Gr, 9MM, FMJ
Shooter - can't hit broadside of a barn, but has a sense of humor about it.


Thoughts?
 

·
Premium Member
Joined
·
874 Posts
did you try to push the trigger forward manually?

How many rounds in the gun?
No one played with the springs before?

Best-case scenario:
- Try with different ammo (maybe too weak?).

worst-case scenario without the gun on my desk:
- Replace RSA, trigger system, trigger bar, firing pin and firing pin spring
 

·
Premium Member
Joined
·
12,892 Posts
This sounds like a Bob question. I can speak for my Glock pistols. I always shoot using first reset ( not letting the trigger go all the way to full reset), and have never had an issue doing so.

Do you have an aftermarket trigger connector installed?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
To answer the questions so far.....

This is a 3 month old G34 Gen5 that is totally stock, out of the box.
No trigger job, no mods, nada.

Pushing the trigger forward was not possible - it was jammed back.

I was running/loading 5 rounds in a mag....concentrating on grouping...so this is not a completely full mag-feeding problem
 

·
Premium Member
Joined
·
3,677 Posts
Well... I've tried for the past hour or so trying to replicate the problem with my G17.5 without success. Nor have I been successful envisioning how the pistol could jam as you've presented. :(

The only way I could create a jam that locked up the pistol was a misfeed caused by a round 'missing' the extractor and the slide slamming on a loose 'crooked' cartridge, wedging it in the slide.

It would be most helpful if you could provide a picture of the position of the slide relative to the frame when the slide jams.

Also, does it jam during the recoil phase or the return phase of the slide cycle?

It's a very interesting problem and I'll continue to work on it... but, at this point, I need a bit more information... and some help. :rolleyes: :D

Best regards,

Bob
 

·
Premium Member
Joined
·
3,677 Posts
Just for grins and giggles, please confirm that the problem wasn't the typical 'failure to extract, double feed' (shown below)...

Failure to extract, double feed 1a.JPG


... or 'failure to feed, nose down' (shown below).

Failure to feed, nose down 1a.JPG


Thanks. :)

Best regards,

Bob
 

·
Premium Member
Joined
·
12,892 Posts
To answer the questions so far.....

This is a 3 month old G34 Gen5 that is totally stock, out of the box.
No trigger job, no mods, nada.

Pushing the trigger forward was not possible - it was jammed back.

I was running/loading 5 rounds in a mag....concentrating on grouping...so this is not a completely full mag-feeding problem
The only time I had a trigger get stuck in fired position was due to the connector. Mine was stuck until I replaced it though. The fact it’s happening not every time has me very curious.
 

·
Premium Member
Joined
·
3,677 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #14
Worked on it this weekend....

I managed to duplicate the action in dry fire - rack, pull trigger all the way back,click, continue holding trigger, try to rack the slide....and it jammed.

Did a full take down and cleaning and lube job, and now it’s 100% again - no malfunction.

Thanks for all the suggestions. Something was just binding up on the last round bolt hold open - fixed with a good clean and lots of lube
 

·
Registered
Joined
·
5 Posts
Worked on it this weekend....

I managed to duplicate the action in dry fire - rack, pull trigger all the way back,click, continue holding trigger, try to rack the slide....and it jammed.

Did a full take down and cleaning and lube job, and now it’s 100% again - no malfunction.

Thanks for all the suggestions. Something was just binding up on the last round bolt hold open - fixed with a good clean and lots of lube
 

·
Registered
Joined
·
5 Posts
Just curious now. Did you previously perform a complete disassembly before you fixed it?
I can purposely reassemble my G19 so the striker will sometimes fall on reset.
 

·
Registered
Joined
·
86 Posts
Let us know if you find the bolt in there that is the problem,
 
1 - 19 of 19 Posts
Top