Glock 26 Gen 4 problem

Discussion in 'Glock Forum' started by cmonty48, Sep 11, 2012.

  1. cmonty48

    cmonty48 New Member

    192
    0
    Bought a new 26 a week ago and I took it out to the range. Unfortunately several times the case wouldn't eject and would get caught in the slide. I was wondering if there's anything I can do myself instead of having to send it back in? I own 2 other gen 4 and have had zero problems with them. Thanx
     
  2. Liftheavybrah

    Liftheavybrah New Member

    29
    0
    I'm fairly new to glock but I've heard that the gen 4 baby glocks have guide rod issues. Have you taken it apart to see if anything is broken or out of place?
     

  3. cmonty48

    cmonty48 New Member

    192
    0
    Yes I cleaned it before I shot it and looked it over again when I got back and everything looked fine. I traded my M&P for this gun because of the problems I had with it. Still shoots alot better than the M&P
     
  4. ezveedub

    ezveedub Premium Member

    What ammo are you using with this Glock 26 Gen4?
     
  5. cmonty48

    cmonty48 New Member

    192
    0
    I used the Winchester white box target load 147 grain
     
  6. GunnerGSP

    GunnerGSP New Member

    My gen4 26, purchased last month, had issues going back into battery when racking the slide. I called Glock and they sent me a new recoil spring assembly without any nudging on my part.

    Inspecting the old RSA showed no visible problems. The new RSA corrected the battery issue, but I have yet to shoot with it.

    This may have nothing to do with your specific issue, but thought I would mention it just in case.
     
  7. cmonty48

    cmonty48 New Member

    192
    0
    Thanks Gunner I'll give them a call
     
  8. ezveedub

    ezveedub Premium Member

    Is this happening with all three magazines? I would try a different ammo before sending it back in. I have a Gen 3 26 and used all types of ammo from 115gr-147gr in regular FMJ and +P JHP with no issues. I know the gen 3 has a dual recoil spring like the gen 4, but I think there is a slight difference still.
     
  9. j102

    j102 Active Member

    3,067
    1
    Yes. Just give them a call. They will send you a new RSA for free and the problem will go away.
     
  10. Firekrotch

    Firekrotch New Member

    2
    0
    It was probably bad ammo, I had the same problem with my 1911